Yaw2 pro, no Yaw, Only Pitch & Roll. Fresh New unit


I just received my Yaw2 Pro

I have Pitch & Roll movement but no Yaw.

I'm connected to the chair using my PC & my phone (using Yaw VR app) and in Test Mode I see the Yaw scroll bar but when I move it ( right & left ) – the rotation platform does not move. (There is no Yaw limit set)

 I opened the Yaw platform and it looks like there is no power coming out of the power unit.

Also, Is it not really dangerous to put a 220V power unit in a metal case? one exposed cable touching the frame with bad grounding and its an electric chair !!!



  • i have the same issue what do we do to fix this?

  • Hi I wondered if you had managed to sort this issue as I have the same issue and despite taking the unit apart about 6 times I am still no closer to having a rotating platform - pitch and roll have always worked fine. Support suggested that I unplug and replug the molex which i have done a few times to no avail.

    Any assistance greatly appreciated

Sign In or Register to comment.