Yaw2 pro, no pitch no roll only rotation works. FreshNew unit


Im looking for help since last week. I have been in contact with Yaw Support since last week but im not sure his suggestion will work.... replace the magnet and usb box.

This is a summary of the situation of my device. I will appreciate any help here, thanks in advance

  1. This a yaw2 pro with rotation platform that used to work well ( without the original magnet but replaced with another magnet i found at home).
  2. I updated the last version of the game engine and after that the simulator only works for the rotation axis when i do the manual test on the app.
  3. I tried to operate the simulator from the PC using the game engine and simstudio application with no success.
  4. Apparently motor and sensors are ok when use the diagnosis on the app ( all green and ok messages).
  5. I separate the rotation platform to operate the pitch and roll unit stand alone, with no success.
  6. i open the pitch and roll unit to check if the cables are disconnected or loose, everything looks ok
  7. i check on the pitch and roll unit if the power has been correctly selected to 110 v ( i live in the USA)
  8. When i open the pitch and roll unit and start the simulator from the app i hear nothing, no fan, no motor sound.... nothing at al although there are some lights here and there inside the unit.
  9. I open the metal part of the seat holder to check if all cables are correctly connected. I noticed that on the flat cable connection side on the back part of the seat holder there are some light that blink in green.
  10. I have open the usb box and bypass the magnet safety mechanism with a metal connector but again nothing works
  11. I you move with your hand the simulator pitch and roll you can see how the pitch and roll changes in the app.
  12. I reset a few times and reinstalled the app

After sharing all this information plus photos and videos taken during the process YAW vr support team concluded that it must the magnet safety mechanism what is failing and need to be replaced.

Im not an expert but i according to app that safety mechanism is working fine ( not emergency message on the app) plus i have connected the two cables of the usb box and the simulator just starts fine without the magnet.

Any help with this case will be highly appreciated. I pay 5000 usd for non functional toy and im in desperate need of help and solutions.....



  • Can anybody help?

  • Hi @netxum, I'm so sorry that you're having issues with Yaw2 Pro unit. I will try my best in helping you to get going.

    It's interesting that it's working when in test mode. I believe it could be game engine issues. Have you tried SRS software instead of Yawvr GE (SIM Racing Simulator) at all? You also need to calibrate the unit before you start a game. In game engine you need to start game plugin for your chosen game by starting game on pc then pause. Then tab into GE to start the plugin and start the Yaw2. Then unpause game.

  • Hi,

    Thanks for helping with this, very much appreciated.

    In the test mode ( manual) only rotation motion works using the yaw mobile app, desktop application or SRS software. If you select the test in auto/random mode you see all the axis moving on the app screen but only rotation really works.

    I will try with that sequence on GE ( game start , pause, start plugging, start and upause the game)....

    It could be a coincidence but this issue happened the same day i updated the version of the GE in my PC. Although i have downloaded the new version of the GE every time i start the GE the messages " there's a new version of this software, do you want to download it" pops up.

    How can i make a factory reset and start an installation from scratch? I uninstalled the Yaw mobile app a few times but when installed again there's no need to do the set up from zero as the app recognise the simulator unit. Shall i delete any other file from my mobile?

    Support team is sending the missing magnet and a new usb box but i don't think this will fix the issue as i override the stop safety mechanism by joining the two cables.....

    The other option they are considering is that there are cases where a unit was connected with wifi and then added a ethernet connection later one and for any reason the system did not send energy to the platforms but i never connected my simulator with ethernet...

    One last thing, on the diagnosis tab of the app there are three circles showing the temperature of the CPU ( top circle) and motors ( two circles left and right). The motor temperature left circle is showing and interrogation mark (?) while the other two shows the temperature.

    I don't know what else to try......

    Again, thanks for doing your best


  • You're very welcome. Right I would uninstall all yawvr files from your pc including mobile apps too. Also uninstall GE including legacy left over files and if you have SRS installed please uninstall that too. Restart pc and mobile.

    Then remove Yaw2 IP address from your router if you can. If possible can you try ethernet cable from Yaw2 to router?

    Install the version of GE that didn't mess up your unit. I would try SRS first before installing GE 2.0

    Setup yawvr config app by ethernet not WiFi as I want to make sure it's not WiFi related (IP interference)

    Please let me know how you get on and I'm here if you need me. Thanks

  • Hi,

    I tried yesterday following your steps with unfortunately no success.

    1. Uninstalled Yaw Configuration app in my phone, SRS software and Game Engine in my PC including other files in these folders.
    2. Restarted Phone and PC and YAW Pro after connecting it with a ethernet cable to my router.
    3. Deleted from my router the YAW Pro IP
    4. Download and Install SRS ( with motion license) and YAW configuration software on my PC
    5. First i tried to connect to SRS to set up the motion simulator without having configure yet the simulator using YAW configuration software, it does not work
    6. Launch YAW configuration software on my PC and completed the set up of the simulator. Did not do the calibration.
    7. Tried the motion test on the YAW configuration software, it only works the rotation like before.
    8. Tried the test feature on the SRS software that now can see the YAW VR connected to the network. None of the movement axis works ( even the rotation)

    If using the YAW PRO Mobile app and check the diagnosis tab i see a WIFI icon showing that apparently the device is still using the wifi network although is connected to the router with ethernet.

    Is there any way to disconnect wifi in the YAW vr?

    What else could i try?

    Thanks for helping

  • did you solve this issue ? if not you could try by opening device manager and delete all drivers associated with yawvr , if you have trouble finding the correct drivers switch the yawvr off and on while device manager is open and you'll see it appear and disappear.

Sign In or Register to comment.